Instalar libdb4.8-dev en Linux Mint

Necesito Instalar libdb4.8-dev en Linux Mint, este paquete sirve para poder compilar la billetera de digitalcoin (o en el caso de cualquier clone de bitcoin/litecoin). Buscando en el apt-cache, me muestra el error que el paquete de desarrollo de la librería libdb4.8 no existe;

E: Package 'libdb4.8-dev' has no installation candidate

Después de un largo rato de buscar, encontré que para compilar cualquier software para bitcoins o en mi caso digitalcoin, hay que agregar el repositorio de Bitcoins para Ubuntu.

Agregar el repositorio de Bitcoin para Debian, Ubuntu y Linux

Empezamos por agregar las siguientes lineas a los archivos fuente de nuestro sistema operativo

deb http://ppa.launchpad.net/bitcoin/bitcoin/ubuntu trusty main
deb-src http://ppa.launchpad.net/bitcoin/bitcoin/ubuntu trusty main

Luego agregamos las llaves GPG obtenidas del repositorio estable de Bitcoin

LMint16 sources.list.d # apt-key adv --recv-keys --keyserver keyserver.ubuntu.com C70EF1F0305A1ADB9986DBD8D46F45428842CE5E
 Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.loiYNJTFZ5 --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/steam.gpg --recv-keys --keyserver keyserver.ubuntu.com C70EF1F0305A1ADB9986DBD8D46F45428842CE5E
 gpg: requesting key 8842CE5E from hkp server keyserver.ubuntu.com
 gpg: key 8842CE5E: public key "Launchpad PPA for Bitcoin" imported
 gpg: Total number processed: 1
 gpg: imported: 1 (RSA: 1)

Como Instalar libdb4.8-dev en Linux vía repositorio

Actualizamos las fuentes de software e instalamos el paquete  libdb4.8-dev, tecleando;

LMint16 sources.list.d # sudo apt-get install libdb4.8-dev
Reading package lists... Done
Building dependency tree 
Reading state information... Done
The following extra packages will be installed:
 libdb4.8
Suggested packages:
 db4.8-doc
The following packages will be REMOVED:
 libdb++-dev libdb-dev libdb5.3++-dev libdb5.3-dev
The following NEW packages will be installed:
 libdb4.8 libdb4.8-dev
0 upgraded, 2 newly installed, 4 to remove and 7 not upgraded.
Need to get 1,165 kB of archives.
After this operation, 2,032 kB disk space will be freed.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/bitcoin/bitcoin/ubuntu/ trusty/main libdb4.8 amd64 4.8.30-trusty1 [553 kB]
Get:2 http://ppa.launchpad.net/bitcoin/bitcoin/ubuntu/ trusty/main libdb4.8-dev amd64 4.8.30-trusty1 [612 kB]
Fetched 1,165 kB in 14s (81.3 kB/s) 
(Reading database ... 237681 files and directories currently installed.)
Removing libdb++-dev:amd64 (1:5.3.21~exp1ubuntu1) ...
Removing libdb-dev:amd64 (1:5.3.21~exp1ubuntu1) ...
Removing libdb5.3++-dev (5.3.28-3ubuntu3) ...
Removing libdb5.3-dev (5.3.28-3ubuntu3) ...
Selecting previously unselected package libdb4.8.
(Reading database ... 237665 files and directories currently installed.)
Preparing to unpack .../libdb4.8_4.8.30-trusty1_amd64.deb ...
Unpacking libdb4.8 (4.8.30-trusty1) ...
Selecting previously unselected package libdb4.8-dev.
Preparing to unpack .../libdb4.8-dev_4.8.30-trusty1_amd64.deb ...
Unpacking libdb4.8-dev (4.8.30-trusty1) ...
Setting up libdb4.8 (4.8.30-trusty1) ...
Setting up libdb4.8-dev (4.8.30-trusty1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.4) ...

Via | Como agregar llaves GPG de respositorios Linux Debian Ubuntu o Mint

Comentario, Preguntas o agradecimientos?

%d bloggers like this: