Como Instalar Telegram Messenger en Linux 4

Chatear con Telegram desde Linux

Me acabo de enterar que se puede utilizar el app de android Telegram para chatear desde el Windows de la computadora. Me tope con la grata sorpresa que los desarrolladores de Telegram también han incluido Linux como sistema cliente, el problema que es un chat de texto, en fin, acá les paso el tip de como instalar y ejecutar Telegram desde Linux.

Clonamos el repositorio de Telegram

Lo primero es descargar las fuentes del programa, así que procedemos a clonar el repositorio de Telegram;

 git clone https://github.com/vysheng/tg.git && cd tg

Instalación de Telegram En Debian, Linux Mint o Ubuntu

Instalamos el software requerido para dar soporte al cliente de Telegram;

 sudo apt-get install libreadline-dev libconfig-dev libssl-dev lua5.2 liblua5.2-dev

Instalación en Fedora

 sudo yum install lua-devel openssl-devel libconfig-devel readline-devel 

Ahora procedemos a configurar y compilar las fuentes en el directorio de Telegram de nuestro PC;

 ./configure
 make

Ejecutando Telegram Messenger desde la terminal de Linux

Telegram Messenger con LinuxYa todo esta listo, solo falta ejecutar el programa y completar la información de su móvil:

./telegram
Ahora nos pide nuestro numero de teléfono, no olviden el + para código de país. Recibirán un mensaje de Telegram en su teléfono con el código requerido para activar el chat desde la terminal de linux

Comandos básicos de Telegram desde la terminal

Empezamos por ver el listado de sus contactos ya existentes;

 contact_list

Ahora si desean mandar un mensaje al móvil de su contacto tan solo escriben msg y el nombre del contacto completo tal y como aparece en la lista:

msg Nombre_Del_Contacto

Via | Telegram Messenger para Linux

4 thoughts on “Como Instalar Telegram Messenger en Linux

  1. Reply Edov-Soft May 5,2014 20:38

    Desde que salio le vi buena pinta al Telegram y con esto me sorprendió bastante, gracias por el post pero se me presento el siguiente problema:
    Tengo Ubuntu 12.10 y cuando ejecute
    $ sudo apt-get install libreadline-dev libconfig-dev libssl-dev lua5.2 liblua5.2-dev
    me presento este mensaje:
    $ sudo apt-get install libreadline-dev libconfig-dev libssl-dev lua5.2 liblua5.2-de
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Note, selecting ‘liblua5.2-dev’ for regex ‘liblua5.2-de’
    libconfig-dev is already the newest version.
    libreadline-dev is already the newest version.
    liblua5.2-dev is already the newest version.
    lua5.2 is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libssl-dev : Depends: libssl1.0.0 (= 1.0.1c-3ubuntu2) but 1.0.1c-3ubuntu2.5 is to be installed
    E: Unable to correct problems, you have held broken packages.

    Gracias por los aportes

    • Reply fher98 May 6,2014 12:27

      Mmm eso de broken packages te va a dar clavos… proba:

      sudo dpkg –configure -a –force-all

      sudo apt-get clean

      sudo apt-get update

      • Reply Edov-Soft May 6,2014 19:51

        gracias mano, buena onda
        ya no me dio el clavo de dependencias ahora al ejecutar el make me da lo siguiente:
        gcc -g -O2 -I/usr/local/include -I/usr/include/lua5.2 -DHAVE_CONFIG_H -Wall -Wextra -Werror -Wno-deprecated-declarations -fno-strict-aliasing -fno-omit-frame-pointer -ggdb -I. -I. -c main.c -o main.o
        In file included from main.c:52:0:
        mtproto-client.h:23:24: fatal error: openssl/bn.h: No such file or directory
        compilation terminated.
        make: *** [main.o] Error 1

Comentario, Preguntas o agradecimientos?

%d bloggers like this: